Community

コミュニティをご利用の際は 【ガイドライン】を確認・同意いただいた上でご利用ください。

  • 投稿

    アバターyusuke

    従業員情報 更新APIについて

    人事労務APIの従業員情報 更新(/api/v1/employees/{id})について質問です。

    API レファレンスより
    company_id、year、monthのみが必須項目であると認識しておりますが
    birth_date、entry_dateを含めなかった場合、
    500エラーが以下のメッセージと共に生じてしまいます。
    message: エラーが発生しました。再試行しても解消しない場合は、サポートセンターまでご連絡ください。

    こちらは必須項目となっているのでしょうか。

    よろしくお願いいたします。

    回答

    freee dev-supportfreee dev-support

    ご報告ありがとうございます。
    手元でも500エラーになることを確認できました。
    担当部署にフィードバックいたします。

    ご迷惑をおかけしてしまいますが、
    birth_date, entry_date
    を指定してご利用ください。

    引き続きどうぞよろしくお願いいたします。