アバターaid

ありがとうございます!解決しました。

curl打ってて、ヘッダーに Content-Typeを追加してなかったことに、ふと気づきました。

下記でいけました。ありがとうございました!

 

var freeeApp = getService();
var accessToken = freeeApp.getAccessToken();
var requestUrl = “https://api.freee.co.jp/api/1/deals”;
var headers = {“accept”: “application/json”, “Content-Type”: “application/json”, “Authorization” : “Bearer ” + accessToken };
var options = {
“method”:”POST”,
“headers”:headers,
“payload”:JSON.stringify(requestBody),
muteHttpExceptions: true
};
var res = UrlFetchApp.fetch( requestUrl , options );